PROBLEM

Element displays as 'No Data' and 'Cannot Access Data' in ArcGIS Dashboards

Last Published: November 22, 2022

Description

A data-driven element backed by published data referencing a geodatabase source displays as 'No Data' and 'Cannot Access Data' in ArcGIS Dashboards.

The No Data and Cannot Access Data messages in ArcGIS Dashboards

Cause

In a dashboard, elements such as an indicator, gauges, pie charts and serial charts rely on the underlying data source's ability to generate summary statistics when queried. If the layer is incapable of performing statistics, the necessary summary statistics are not generated.

Solution or Workaround

Use query layers to query data from the database or geodatabase. Refer to ArcGIS Blog: Using query layers in Operations Dashboard for more information.

Article ID:000023698

Software:
  • ArcGIS Online
  • ArcGIS Dashboards

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic