PROBLEM

Issue with the ArcGIS License Manager service when upgrading, or uninstalling and re-installing, if Named User licenses through an ArcGIS Enterprise Portal are offline

Last Published: April 12, 2024

Description

In some cases, upgrading ArcGIS License Manager software when Named User licenses through an ArcGIS Enterprise Portal are offline, may cause issues with the ArcGIS License Manager service.

This can occur when upgrading ArcGIS License Manager, or uninstalling and installing a newer version of ArcGIS License Manager. and may cause the License Manager service to fail if Named User licenses served through an ArcGIS Enterprise Portal are offline.

The issue does not occur when only Concurrent Use licenses are borrowed.

Cause

An incomplete uninstall of the Flexnet Licensing Service may cause the newly installed License Service to improperly start.

Solution or Workaround

If the uninstall or upgrade has not been started

  1. Stop the License Manager service.
  2. Open the License Server Administrator.
  3. In the Start/Stop License Service dialog of the License Server Administrator, press Stop.
  4. Close the License Server Administrator.
  5. Proceed with the in-place upgrade, or uninstall and install the newer ArcGIS License Manager.

If the uninstall or upgrade has been completed and the ArcGIS License Manager is non-operational

  1. Close the License Server Administrator.
  2. Uninstall ArcGIS License Manager.
  3. Re-install the last-installed (previous) version of ArcGIS License Manager.
  4. Confirm ArcGIS License Manager is operational again.
  5. Open the License Server Administrator if applicable.
  6. In the Start/Stop License Service dialog of the License Server Administrator, press Stop.
  7. Close the License Server Administrator.
  8. Proceed with in-place upgrade or uninstall and install of the newer ArcGIS License Manager.

In upgrades from ArcGIS License Manager 2024.0 to later versions, for example, to ArcGIS License Manager 2024.1 or newer, the issue is resolved and no action is required.

Note that upgrades from an older version to ArcGIS License Manager 2024.0 are impacted by this issue.

Article ID: 000032434

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options