ERROR

Unable to add item in Portal for ArcGIS

Last Published: May 5, 2025

Error Message

When attempting to create a layer in Portal for ArcGIS by selecting Content > New Item > Feature Layer, the following is returned:

There was an error while adding this item.

error displayed in the New item dialog

The intermittent issues in publishing new hosted feature services in Portal for ArcGIS with the following methods: Define your own layer and Use a template.

Cause

This issue can stem from a variety of causes, including permissions issues, item size limitations, or connectivity problems.

Solution or Workaround

Depending on the cause, use one of the following options to resolve the issue.

Monitor Resource Usage on the Server

  • Check the CPU, memory, and disk usage of the server hosting Portal for ArcGIS and ArcGIS Server.
  • If the server is under heavy load or resource limits are being reached, try increasing resources, for example, adding RAM, increasing CPU, or freeing up disk space.
  • Review the ArcGIS Server logs to see if any resource-related errors or warnings are logged during the service publishing process.

Increase Timeout Settings

  • If the issue is related to publishing large datasets, consider increasing the timeout settings in ArcGIS Server or Portal to allow for longer processing times.
  • Modify the timeout settings in the ArcGIS Server Manager or the Portal configuration files.

Test with Smaller Datasets

  • Try publishing a simpler or smaller dataset to test if the issue is related to the size or complexity of the data.
  • If a smaller dataset works consistently, it could indicate that the issue is tied to the size or complexity of your larger datasets.

Troubleshooting Files Shares and ArcGIS Enterprise

  • ArcGIS Enterprise architectures often have requirements for use of file shares for storage of shared configuration files, content, or backups. See: Choose a NAS device for ArcGIS Server. This is particularly true when the deployment pattern involves multiple machine sites (such as the high-availability configurations). There are uses of file shares across each of the main ArcGIS Enterprise components (Portal for ArcGIS, ArcGIS Server, and ArcGIS Data Store).
  • This is outlined in an Esri Community Post that can be implemented:
    • Here is how to do it if you are a local machine administrator for the client OS. 
      1. Open a PowerShell command window as an Administrator and note the current settings:
      2. Run the commad: Get-SmbClientConfiguration
      3. Then, you can change them. The following commands disable all client-side caching:
Set-SmbClientConfiguration -DirectoryCacheLifetime 0
Set-SmbClientConfiguration -FileNotFoundCacheLifetime 0
Set-SmbClientConfiguratoin -FileInfoCacheLifetime 0
  • Note that the changes take effect the next time the client establishes a new connection to the file share. Restarting the Esri ArcGIS Server software does this.

Article ID: 000035006

Software:
  • Portal for ArcGIS

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