ERROR

Unable to print the maps using default Utilities > PrintingTools Service

Last Published: March 28, 2025

Error Message

In a multi-machine deployment for ArcGIS Enterprise 11.x or older releases, printing maps sometimes doesn't work properly and gives an error. It is very difficult to troubleshoot this as it shows status "Started" in ArcGIS Server Manager or Admin end point.

Commonly, the below error messages are returned.

Error executing tool. Export Web Map Task : Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service1_Name>/MapServer.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service2_Name>/MapServer.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service3_Name>/FeatureServer/0.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service4_Name>/FeatureServer/1.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service5_Name>/FeatureServer/0.
Failed to execute (Export Web Map).
Failed to execute (Export Web Map Task).
An unexpected error occurred while printing from Map Viewer on ArcGIS Enterprise Portal.

Some examples of how this appears when printing from a custom application are shown in the following screenshots.

Error while printing from custom applications

Error details

Cause

There are a variety of reasons for this issue. 

  • The default Printing Tools service URL is not configured in: ArcGIS Enterprise Portal > Organization > Settings > Utilities services > Printing
  • The SSL Certificate is not configured properly on each component of ArcGIS Enterprise.
  • Cases where there is a DMZ (Demilitarized Zone) or MZ (Militarized Zone) separation of machines in the environment, for example, ArcGIS Enterprise components are separated into two zones for different levels of security.
  • Forward proxy is used for accessing the internet on ArcGIS Server machines, if this machine resides in a MZ where there will be no internet to access the online URLs.
  • Internal communication among the ArcGIS Enterprise component machines is not happening properly. Required connectivity and ports must be checked.

Solution or Workaround

The steps provided below have worked in High-Availability configurations for ArcGIS Enterprise 11.x.

  1. Configuring the default Printing Tools service URL in: ArcGIS Enterprise Portal, Organization tab > Settings > Utilities services > Printing
https://machine.domain.in/arcgis/rest/services/Utilities/PrintingTools/GPServer
  • where "machine.domain.in" is the Public DNS configured to make ArcGIS Enterprise accessible over the internet. Otherwise, it is the ArcGIS Enterprise Portal URL.
  1. Configuring the SSL Certificate properly on each component of ArcGIS Enterprise:
    • Configure the applicable CA-Signed or Domain-Signed SSL certificate on each machine:
      • ArcGIS Server (Hosting) - Each machine participating
      • ArcGIS Enterprise Portal - Both Primary and Standby
      • ArcGIS Datastore - Both Primary and Standby
      • Any other ArcGIS Server Roles / machines federated with ArcGIS Enterprise
  1. If there is DMZ or MZ separation of machines in the environment and forward proxy is used for accessing internet on ArcGIS Server machines, configure a forward proxy server with ArcGIS Server on 11.x using these steps:
    1. Log in to the following URL with Primary Site Administrator account:
https://machine.domain.com:6443/arcgis/admin 
  1. Click System > Properties > Update

Refer to the instructions below to configure the forward proxy for Windows and Linux machines:

Article ID: 000032732

Software:
  • ArcGIS Enterprise

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