Error Message
At the Arc prompt, the PLOT <graphics_file> command returns:
Code:
Unable to open pltque file.
Cause
The pltque file does not exist at all, or if it does, it is not in a location ArcInfo can access, or the file contents are not in the correct format.
Solution or Workaround
- Check the $HOME and $ARCHOME/sysgen directories for the pltque file. At the Arc prompt type:
Code:
ls $HOME/pltque
ls $ARCHOME/sysgen/pltque
If it does not exist, create it with a text editor. See step three.
Note:
A pltque file in the $HOME directory will be used before the one in $ARCHOME/sysgen.
- On systems running multiple installations of ArcInfo, it is possible the pltque file is in a different $ARCHOME location from the one you are using. Check the various $ARCHOME locations your system may have. If you find a pltque file, copy it to the location that corresponds with the installation you are using.
Note:
See your system administrator for assistance with this.
- Verify the pltque file has four lines for each output device as follows:
Line 1: (Destination) The name of the device as it appears in the PLOT dialog box.
Line 2: (Mode) How and where your map is translated to a native printer language (direct, filtered, or serveware).
Line 3: (Queue) The name of the spooling queue that directs your map to the correct device. This queue is used by the operating system commands lp or lpr. Use lpstat -a to view queues recognized by your system.
Line 4: (AML) Reference to an AML that provides a PLOT interface menu for each printer driver translator. It allows you to select printer-specific parameters and to send the file to the printer. Default amls are located in the $ARCHOME/atool/support/plotsupport directory.
Here is a sample pltque file:
cal5800 (CalComp 58000 plotter)
direct
cal5800
$ARCHOME/atool/support/plotsupport/cal5835.aml
For more details, see the ArcDoc topic "Creating the plot queue file" found under Contents > System Administration > System Setup > Setting up and customizing the plot system > (your UNIX platform).