PROBLEM

Unable to fetch the Data Interoperability for Pro extension Concurrent Use license from ArcGIS License Manager

Last Published: August 26, 2024

Description

Although the ArcGIS Pro main license and Data Interoperability for Pro extension license were authorized in the License Server Administrator, when attempting to configure ArcGIS Pro installed in the network machine with License Manager, the following message is returned:

 “Unable to check out the requested extension Data Interoperability”.

example of error message

Cause

This error may occur due to the unavailability of the Data Interoperability for Pro extension license in the ArcGIS License Manager, or may be due to restrictions created through the Options file configured in the ArcGIS License Manager.

Solution or Workaround

  1. Check the number of available Data Interoperability for Pro extension licenses in ArcGIS Pro Licensing pane or in the ArcGIS License Server: Administrator > availability.
  2. Check for options file ARCGIS.opt in the default location C:\Program Files\ArcGIS\LicenseManager\bin in the ArcGIS License Manager installed machine.
  3. If there is an Options file present in the mentioned directory, either edit the existing syntax in the Options file or delete the existing Options file to access the Data Interoperability extension from the ArcGIS Pro installed on the network machine.
Note:
To give permissions to the specific license for the particular user through the Options file, refer to: Using the Options file—License Manager Guide.

Article ID: 000033447

Software:
  • ArcGIS Pro
  • ArcGIS Data Interoperabilityx

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options