ERROR

Unable to authorize ArcGIS Pro with Named User License

Last Published: July 8, 2025

Error Message

When attempting to authorize ArcGIS Pro using a Named User license from Portal for ArcGIS, the following error message is returned:

An unknown error has occurred. Contact your administrator to check that the license manager is running with valid licenses.

error message

Cause

This issue may be caused by incorrect information provided while generating the Portal license file (.json). The incorrect information may include:

  • Portal URL (for version 11.4 and later)
  • Licensing Port (for version 11.3 or earlier)
  • Hostname

Solution or Workaround

Generating the license file

  1. Sign into My Esri and click Licensing > Start Licensing.

  1. Select the product as ArcGIS Enterprise, for Version, select the desired ArcGIS Enterprise version; and from the License Type list, select Portal for ArcGIS. Click Next.

  1. Under Select User Type and Application Licenses, view the user types, applications, and extensions that are available for your organization. Select the number of licenses for each user type, application, and extension to include in your license file. Click Next.

Note:
If you have ArcGIS Pro or ArcGIS Pro extensions available to your organization, select the number of add-on ArcGIS Pro licenses and ArcGIS Pro extensions. Click Next.
  1. In Portal for ArcGIS version 11.4, a portal URL is required when generating the license file. If you have a public URL to be configured as the WebContext URL for your portal, you must use it instead of a local URL during license file generation.

  1. Review all the information for accuracy, confirm that the details are correct, and choose the delivery method for your license file: either Download or Email, and click Create File.
Note: 
For ArcGIS Enterprise versions 11.3 or earlier, if your ArcGIS License Server Administrator is running on a non-default port (i.e., other than 27000), you must generate the license file using that specific port.
To check the running port of ArcGIS License Server Administrator: Open ArcGIS License Server Administrator > Diagnostics > View, and check the Listening port, as shown in the next image.

Article ID: 000035854

Software:
  • ArcGIS Pro
  • Portal for ArcGIS

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