ERROR

Unable to add datastore to the server. The server has a data store with the same name

Last Published: April 11, 2025

Error Message

In Portal for ArcGIS, a user-managed data store that was previously registered with the hosting server shows as not being registered with any of the federated ArcGIS servers.

no federated servers seen in the data store

Attempting to register the data store with the hosting server fails with the following error:

Unable to add datastore to the server. The server has a data store with the same name.

error seen when message when trying to register the data store

Cause

The data store item details that store the list of registered federated servers have become corrupted. The exact cause of the corruption is unknown. 

Solution or Workaround

To solve this issue, we will copy a file from a working datastore item and add it to the items that cannot be registered, as follows:

  1. In Portal Home, find all the datastore items.
  2. Identify a datastore item where the data store is still registered with the federated ArcGIS Server.

copy the item's id from its URL

  1. Using the item ID of the datastore item, search for the item in the Portal content directory.
    The item's ID can be seen in the item's URL. For example:
../portal/home/item.html?id=9b5e410a12314f9386677a71f0f07b9e#settings

search for the item in the portal content directory

  1. Copy the servers file from the working datastore item, and paste the file into the portal content directory for each of the datastore items where the existing federated server cannot be registered with the datastore.

Article ID: 000034009

Software:
  • Portal for ArcGIS

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options