ERROR

Unable to access the Business Analyst Web App

Last Published: October 1, 2025

Error Message

After setting up ArcGIS Business Analyst Enterprise, accessing the Business Analyst Web App from the Portal for ArcGIS app launcher fails, and an error similar to the following is returned:

This page can't be found
No webpage was found for the web address: https://<domain>/portal/apps/BA
HTTP ERROR 404

Cause

URLs are not redirected and/or updated from the portal admin page of the Business Analyst Web app.

Solution or Workaround

The ArcGIS Business Analyst Server role should be listed in ArcGIS Server Manager. Update the URLS from the portal admin page.

  1. Log in to the Portal Administrator Directory.
  2. Update the app info by clicking Security > OAuth > Update App Info.

  1. Copy and paste the following JSON into the App Info section.
    After pasting, make sure to replace the domain.com values under both http and https with your actual domain name. Click Update App.
   {
 "appId": "busanalystonline_2",
 "redirectURIs": [
   "https://*.arcgis.com",
   "https://*.arcgis.com",
   "https://*.domain.com",
   "https://*.domain.com",
   "urn:ietf:wg:oauth:2.0:oob"
 ]
}
  1. Access the Business Analyst web app from the app launcher or browse to:
https://<PortalName.domain.com>/WebAdaptor/apps/BA
Note: 
Only portal members licensed to use the Business Analyst Web App can access it. 

Article ID: 000032653

Software:
  • ArcGIS Business Analyst Enterprise
  • ArcGIS Business Analyst Web App

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