PROBLEM

Tiled glitches and visual artifacts for some users in ArcGIS Pro 3.4

Last Published: June 23, 2025

Description

In ArcGIS Pro 3.4, some users may notice glitching and artifacts on certain machines running Intel GPUs. These may look like random squares or rectangles of color in a map, appearing even when only a basemap is visible. 

Cause

This visual artifact is caused by using an older driver for the Intel GPU and working in DirectX 12. While DirectX 12 has been available for use in Pro since version 3.3, it is now the default for Pro 3.4, making the issue appear more frequently.

Solution or Workaround

This issue was reported to Intel and it has been confirmed that more recent versions of the driver fix the artifacts. It is best to check the version and install date of your driver, then upgrade to the latest if it is out of date. To check this, navigate to Device Manager on your machine, then go to Display Adaptors and open the properties of the listed adaptor. This displays the driver version and install date.

If the GPU driver is out of date, update the GPU driver from the manufacturer’s website or from the laptop manufacturer’s site. For Intel GPUs, the drivers can be found at this link: Intel Driver and Support Assistant

Updating the GPU driver may take some time, you can also switch back to using DirectX 11, the default in Pro 3.3. Alternatively, OpenGL can be used.

Article ID: 000034307

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