ERROR

There was an error communicating with the server. Please check your URL and your credentials and try again

Last Published: April 25, 2020

Error Message

Attempting to federate ArcGIS for Server with Portal for ArcGIS results in the following error:

"There was an error communicating with the server. Please check your URL and your credentials and try again."
[O-Image]

Cause

This is a known issue when Portal for ArcGIS is accessed via a Domain Naming System (DNS) alias. A mismatch in the Service URL and Administration URL in the certification causes the federation to fail.

Solution or Workaround

Note:
This issue can be resolved by re-registering the Portal Web Adaptor with the DNS alias. If registering the Web Adaptor with the DNS alias fails to resolve the problem, proceed with the steps listed below.
  1. Connect to the Internet Information Services (IIS) Web Server.
  2. Generate a self-signed certificate for the IIS Web Server fully qualified domain name by following the instructions in the ArcGIS Resources: Enabling SSL using a self-signed certificate document.
  3. Bind the self-signed certificate to port 443.
  4. Launch a web browser from the IIS Web Server, and navigate to the Portal via the IIS Web Server fully qualified domain name (FQDN) URL and Web Adaptor URL.
  5. Run the federation process between ArcGIS for Server and Portal for ArcGIS.
  6. Validate the federation through the Portal page via the FQDN or Web Adaptor of the IIS Web Server.
  7. Reset the certificate binding in the IIS Manager to the newly created self-signed certificate.
  8. Verify the federation by connecting to the ArcGIS Server Manager and Admin endpoints to ensure a portal token was requested.

Article ID: 000013288

Software:
  • Portal for ArcGIS
  • ArcGIS Server

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options