ERROR

The Notebook Server upgrade failed to complete… Failed to upgrade the ArcGIS Notebook Server

Last Published: July 11, 2025

Error Message

After upgrading ArcGIS Notebook Server on Linux to version 11.3 or 11.4, the notebook server site becomes inaccessible, and the following error message is returned:

“The Notebook Server upgrade failed to complete… Failed to upgrade the ArcGIS Notebook Server.”

Cause

Upgrading an ArcGIS Notebook Server on Linux from a previous version to 11.3 or 11.4 can lead to the site becoming unavailable if the configuration store, logs and server directories are located within the ArcGIS Notebook Server installation directory. This is primarily due to accidental deletion of all files within the ArcGIS Notebook Server installation directory as part of the uninstallation process. This results in ArcGIS Notebook Server site becoming unavailable.

Solution or Workaround

The following steps are required before upgrading ArcGIS Notebook Server on Linux to 11.3 or 11.4. Review the upgrade process and preparation steps in the following document: Upgrade ArcGIS Notebook Server (Linux containers)

  1. Move the workspace directory for your notebook server to a directory location outside the installation directory by following the instructions in the above document.
  2. Update the notebook server configuration store directory location
    1. Sign in to your ArcGIS Enterprise portal as a user with administrative privileges.
    2. Open the ArcGIS Notebook Server Manager.
    3. Click the Settings tab. Select Configuration Store. Check if the configuration store is located under the notebook server installation directory, for example, /<installdir>/arcgis/notebookserver/usr/config-store. If it is, move the configuration store to a location outside the notebookserver directory by updating the path to the new location, for example, /<installdir>/arcgisnotebookserver/usr/config-store. Select Yes to move the current configuration and click Save.
  3. Update Notebook Server Directories location
    1. Stay in the Settings tab of ArcGIS Notebook Server Manager.
    2. Click Directories in the left pane. Verify if the arcgisoutput, arcgisjobs, and arcgissystem directories are under the notebook server installation directory, for example,  /<installdir>/arcgis/notebookserver/usr/directories. If they are, move them to to a location outside the notebookserver directory. For each directory: Click Edit and update the path to the new location, for example, /<installdir>/arcgisnotebookserver/usr/directories/arcgisoutput. Click Save and repeat for arcgisjobs and arcgissystem.
  4. Update Logs Directory location
    1. Stay in the Settings tab of ArcGIS Notebook Server Manager.
    2. Click Logs in the left pane. Check if the Logs directory is under the notebook server installation directory, for example, /<installdir>/arcgis/notebookserver/logs. If it is, move it to a location outside the notebookserver directory. Update the path to the new location, for example, /<installdir>/arcgisnotebookserver/logs. Click Save and manually copy all contents from the old logs directory to the new location.
  5. Backup Deployment
  6. Perform Upgrade

Article ID: 000036784

Software:
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 4

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