ERROR

The geocoding service selected for this dataset is damaged. Do you want to repair it?

Last Published: April 25, 2020

Error Message

When geocoding by an address table with Store or Customer Setup tools, the following error is returned:

"The Geocoding Service selected for this dataset is damaged. Do you want to repair it?"

Cause

This is a known issue.

Solution or Workaround

Check to make sure that the geocoding files are being accessed properly.

  1. Restart Business Analyst.
  2. After launching Business Analyst, use the Store or Customer Setup tools and geocode a table of addresses.
  3. Make sure that the geocoding files have the correct path. From the Business Analyst toolbar, select Preferences. From the Dataset tab, verify that a valid locator is selected in the Address locator's window.
    [O-Image] Preferences dialog box
    These locators can be found in ..\Program Files\ArcGIS\Business Analyst\Data.
  4. Verify that the geocoding files were properly copied over during the install process. These files are found in ..\Program Files\ArcGIS\Business Analyst\Data\USA Geocoding Service. The contents of this folder should be a minimum of 5.45 GB in size.
    If it isn't, recopy the contents of the Business Analyst install DVD #3 into the directory referenced above.

Article ID: 000010423

Software:
  • ArcGIS Business Analyst Desktop

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options