PROBLEM

The ArcMap display does not fully refresh after using scroll bars

Last Published: October 1, 2025

Description

After scrolling in either data view or layout view, some parts of the ArcMap display do not draw or refresh completely.

Cause

There are many reasons why the display may not refresh completely. This is usually caused by interrupting the redraw while scrolling. If you click to scroll, and then click to scroll again while the display is still redrawing it may not refresh completely. Other causes may include network latency, low memory, conflicts with third-party tools, etc.

Solution or Workaround

Manually refresh the display by clicking on the refresh button [O-Image] ArcMap refresh button or by pressing the F5 key. If this does not help, see the web help topic, Tips on improving map display performance. See also the GeoNet blog: Troubleshooting Slow Performance in ArcGIS for Desktop

Article ID: 000002774

Software:
  • ArcMap

Get support with AI

Resolve your issue quickly with the Esri Support AI Chatbot.

Start chatting now

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Start chatting now

Go to download options