ERROR

The ArcGIS Server Manager service on Local Computer started and then stopped

Last Published: April 25, 2020

Error Message

When starting the ArcGIS Server Manager after installing Service Pack 2 or Service Pack 3 for ArcGIS Server 9.2, the following error message diplays:

"The ArcGIS Server Manager Service service on Local Computer started and then stopped.
Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service."

Cause

The ArcGIS Server Manager Service and the ArcGIS Server Object Manager Service must be stopped prior to applying ArcGIS Server Service Pack 2 or Service Pack 3. If these services are not stopped, .jar files needed for proper functioning of ArcGIS Server are not copied to the appropriate installation location.

If the ArcGIS Server Manager Service Windows service is shutdown before installing SP2 or SP3, all files are updated correctly.

There are several ways to verify if this issue is being encountered. The three most common ways are as follows:

1. Verify that the following files are indeed missing (after deploying SP3 or SP2) under the $ARCGIS_HOME\java\manager\services\lib directory:
- arcgis_manager.jar (this is what causes the Manager failure)
- arcobjects.jar (missing this file manifests errors in SDK related tasks, such as customization)
- jpe2_sdk.jar (missing this file manifests errors in SDK related tasks, such as customization)

Note:
$ARCGIS_HOME refers to the ArcGIS Server installation directory (for example, C:\Program Files\ArcGIS)


2. In addition to the above files that may be missing, there may be an error in the manager_stderror.txt log, located at $ARCGIS_HOME\java\manager\services\lib\logs
java.lang.NoClassDefFoundError: com/esri/arcgis/manager/server/Main


Note:
This error only appears after an attempt to start the ArcGIS Server Manager Service service.


3. The following entry may also be recorded in the Event Viewer (under Application logs):

Event Type: Error
Event Source: ArcGIS Server Manager Service
Event Category: None
Event ID: xxxx
Date: XX/XX/20XX
Time: xx:xx:xx XM
User: N/A
Computer: <machine_name>
Description: The description for Event ID (xxxx) in Source (ArcGIS Server Manager Service) cannot be found.
The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer.
You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details.
The following information is part of the event: ArcGIS Server Manager Service.

Solution or Workaround



  • One way to solve this problem is to re-deploy the ArcGIS Service Pack (SP3 or SP2) and verify that the arcgis_manager.jar file (and other files mentioned above) is copied under the $ARCGIS_HOME\java\manager\services\lib folder. Detailed steps for re-deploying the ArcGIS Service Pack (SP2 or SP3) are provided below:
    1. Launch the Windows Task Manager and identify the ArcGIS Server Manager Java process.
    2. Stop the ArcGIS Server Manager Service and the ArcGIS Server Object Manager Service. Using the Windows Task Manager, verify that the ArcGIS Server Manager Java process has been terminated.
    3. Apply the ArcGIS Server Service Pack installation again.
    4. Restart the ArcGIS Server Manager Service and the ArcGIS Server Object Manager Service.
  • Another way to fix this issue is to run a Repair on the existing ArcGIS Server installation. The required steps are provided below:
    1. Under Control Panel, double click on Add or Remove Programs.
    2. Select 'ArcGIS Server for the Java Platform', click Change.
    3. Select Repair and run the install.
    4. After repairing the installation, all those missing JAR files are installed.

    Run the Post Install and reboot the machine after these steps.

Article ID: 000009595

Software:
  • ArcGIS Server

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options