PROBLEM

The ArcGIS Flight application is not able to communicate with the drone

Last Published: April 29, 2025

Description

ArcGIS Flight is not communicating with the drone/controller. If the wrong cable is used or a different app is already connected to the drone, the ArcGIS Flight app will simply show a Disconnected status for the drone, even if the correct drone model was selected.

No error messages are displayed when this issue is encountered, as the controller is not communicating anything to the iPad.

Cause

  • Some 3rd-party cables are meant to only be used for charging and not data transmission, this prevents the connection between the app and the controller.
  • Most drones can only connect to one app at a time; Once the drone is connected to one, other apps will simply show that no drones are available and remain disconnected

Solution or Workaround

Make sure the iPad is connected to the controller using a genuine Apple cable to ensure proper communication.

Also ensure that no other apps, for example DJI Pilot and DJI GO 4, were connected to the drone after turning it on.

Article ID: 000035876

Software:
  • ArcGIS Flight

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