PROBLEM

Setup dialog windows display as blank on Linux when running via a VNC connection

Last Published: October 20, 2021

Description

When running Setup for an Esri product on Linux via VNC, the Setup window appears blank.

Cause

There is an issue when using certain VNC connection settings, specifically setting Color Depth to 32-bit, that cause the windows to render incorrectly as blank.

Solution or Workaround

Updating the server’s VNC configuration to use 24-bit color depth, followed by a restart of the VNC server, fixes this issue.
The following example describes the steps to do this on a system using TigerVNC running on RedHat Enterprise Linux 8.

  1. Stop the VNC server. It may be necessary to consult VNC server documentation for instructions on how to start and stop VNC Server, but this is generally done either with the Linux command systemctl stop <myVncServer.service>, or by running the vncserver -kill command <process of running VNC Server>.
  2. Use a text editor to open your VNC server config defaults. In this example for TigerVNC Server, it is found in:
/etc/tigervnc/vncserver-config-defaults
Note:
Saving these changes requires root privileges on most machines.
  1. Update the VNC server to not use 32-bit color depth; this can be done two ways:
    • Comment out the line in your config file that specifies: depth=32
      for example, change it to # depth=32
    • Alternatively, update or explicitly add a line to the file to set 24-bit depth instead:
      depth=24
  2. Save the changes and restart the VNC server as normal, following the VNC Server documentation.
  3. Re-run the Setup and the windows now display normally.
Note: 
Many Esri setups can be run silently via the command line. If this is preferable to updating your VNC settings, check the Setup for silent installation instructions by running './Setup -h' to see if a silent mode installation is provided.

Article ID: 000026659

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