BUG

Return error SE_LOST_DBMS_Connection(-409) to ArcIMS when a dbms is shutdown or when a session is not available

Last Published: March 5, 2021

Description

Note:
The information in this article applies to retired product ArcIMS.

** This issue is addressed in ArcIMS 9.1 Service Pack 1 (SP1) **

Currently, the ArcIMS spatial server is designed to reconnect to ArcSDE when a network I/O error -10 is returned.

When a session is shutdown in Oracle, responds:

Error:
[Sep 7, 2005 2:14:40 PM][3840 3888 ERROR] [ERR2407] (SDE error code -51 ) SE_stream_fetch : Underlying DBMS error
[Sep 7, 2005 2:14:40 PM][3840 3888 ERROR] ORA-01012: not logged on

When Oracle is shutdown and features are requested, the error message returned is:

[Sep 7, 2005 2:57:38 PM][3840 3888 ERROR] [ERR2407] (SDE error code -51 ) SE_stream_fetch : Underlying DBMS error

[Sep 7, 2005 2:57:38 PM][3840 3888 ERROR] ORA-03114: not connected to ORACLE

In both the above situations, the spatial server will not attempt to reconnect, but no error message is displayed.

Cause

This is a known issue.

Workaround

** This issue is addressed in ArcIMS 9.1 Service Pack 1 (SP1) **

The return error SE_LOST_DBMS_Connection(-409) to ArcIMS displays when a dbms is shutdown or when a session is not available.

Article ID:000008322

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