PROBLEM

Visual elements replaced with white space when exporting reports to Excel in ArcGIS Pro

Last Published: July 1, 2025

Description

In ArcGIS Pro, when exporting reports to Excel using the Export Report button, embedded maps or graphical elements do not render correctly and are instead displayed as blank white space. The Excel file below shows the blank white space in the report.

The blank white space in the exported report

Cause

This is a known limitation when exporting reports with visual elements such as maps, charts, graphics, and attachments using the Export Report button. Only the text content is retained, while the visual elements are excluded.

Solution or Workaround

Note:
This workaround is applicable in ArcGIS Pro 3.5 or later. For instructions to update ArcGIS Pro, refer to ArcGIS Pro: Update ArcGIS Pro.
  1. Open the ArcGIS Pro project.
  2. Export the report to an Excel file using the Export Report To Excel tool.
    1. On the Analysis tab, in the Geoprocessing group, select Tools.
    2. In the Geoprocessing pane, search for and click Export Report To Excel.
    3. For Input Report, select the report from the drop-down list.
    4. For Excel File, click Browse and navigate to the preferred location. Specify an output name and click Save.
    5. Expand the Export Excel Options node and ensure the Remove Vertical Whitespace check box is checked.
    6. Click Run.

The Excel file below shows the report with no white space and the visual elements retained.

The report without white space in Excel

Article ID: 000036216

Software:
  • ArcGIS Pro

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options