PROBLEM

User-managed data store timeout when publishing layers in bulk

Last Published: April 25, 2020

Description

In Portal for ArcGIS, attempting to publish a bulk of records using the Publishing tool from ArcGIS Server fails, returning the following error message after running for about an hour:

Error:   
An unknown error occurred. The operation may not have completed successfully.
In the ArcGIS Server logs, the following error message: 
Error:   
The containing process for 'System/PublishingToolsEx' job 'job_number' has crashed.

Refer to  Portal for ArcGIS: Publish layers in bulk from a user-managed data store for more information.

Cause

Publishing a large number of records causes the service to time out, as a large record service needs more time to be processed and published. This varies depending on the complexity of the services such as the number of layers or number of records. 

Solution or Workaround

To resolve this issue, increase the "maxUsageTime" parameter to a higher value to allow the process to finish before the services time out.

  1. Access the ArcGIS Server Administrator Directory, and log in to the admin endpoint with the Primary Site Administrator account.
  2. On the Home page, click Services > System.
  3. Under Services, click PublishingTools (GPServer).
  4. Scroll to the end of the page, and click Edit.
  5. Search for and edit the "maxUsageTime" parameter to a higher value. The default value is 3600 seconds (1 hour). Click Save Edits.​​​​​​
Image of the Service Properties for Edit GPServer
  1. Re-attempt the bulk publishing workflow. 

Article ID: 000021579

Software:
  • ArcGIS Online
  • ArcGIS Server

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