PROBLEM

US Address - Dual Range address locator created with ArcGIS Desktop or ArcGIS Pro does not return matches

Last Published: April 24, 2024

Description

US Address - Dual Ranges address locators created with ArcGIS Desktop (versions 10.1 and above) or ArcGIS Pro (versions 1.0 and above) do not return matches, regardless of whether a zone is used to build the locator, when used in ArcGIS Desktop, ArcGIS Pro, or when published as a geocode service to ArcGIS Enterprise. 

Cause

The default setting for the 'Match with no zone' property in the Address Locator Properties under Geocoding Options is set to No. This prevents any address from being matched that does not include zone information (city, state, or zip code). 

Solution or Workaround

There are two options to fix this problem. One option fixes a specific address locator (for ArcMap or ArcGIS Pro), and the other option permanently sets the default setting of the Match with no zone property to Yes so that all address locators are created with the property set as Yes/True in the future.
 

Method 1a: Specific address locators in ArcMap
  1. In ArcCatalog or the Catalog window, right-click the address locator.
  2. Click Properties.
  3. In the Geocoding Options section, change Match with no zones from No to Yes.

    Address Locator Properties
Note:
Whenever any locator property is changed and the address locator is being used in the current ArcMap session, the address locator must be removed and re-added to the session for the property change(s) to take effect. This can be done using the Geocoding toolbar drop-down > Manage Address Locators. Additionally, any geocode services that refer to the locator being modified must be stopped. 

This does not apply to ArcGIS Pro. Any locator property changes are reflected immediately in the project and there is no need to remove and re-add the address locator. 


Method 1b: Specific address locators in ArcGIS Pro
  1. Open the Catalog pane (View ribbon and Windows group) or Locate pane (Map ribbon and Inquiry group), and ensure the address locator has been added to the project.
  2. In the Catalog pane, right-click the address locator under the Locators folder and navigate to Locator Properties. Or, in the Locate pane, go to the Settings tab and click the View/Edit Properties button (pencil icon).
  3. In the Geocoding Options section, change Match with no zones from No to Yes.
     
    User-added image
     
Method 2: Permanently set the 'Match with no zones' default setting to Yes/True
  1. In an XML editor or text editor, open the USAddress.lot.xml file located in C:\Program Files\ArcGIS\Desktop10.x\Locators or C:\Program Files (x86)\ArcGIS\Desktop10.x\Locators (ArcGIS Desktop) or C:\Program Files\ArcGIS\Pro\Resources\Locators (ArcGIS Pro).
    Note:
    Substitute '10.x' in the address above to match the version of ArcMap in use.
  2. Change the two occurrences of the following tag from false to true.
     
    Before:
    <prop name="supportsOptionalZone" type="Boolean">false</prop>
    After:
    <prop name="supportsOptionalZone" type="Boolean">true</prop>
    Any new address locators created will have this setting applied by default.
    Note:
    In ArcGIS Desktop versions 10.2 and higher, there are approximately two to four occurrences of the supportsOptionalZone property. New search methods have been added over time that include this property.

Article ID: 000011688

Software:
  • ArcMap
  • ArcGIS Pro
  • Enterprise

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options