PROBLEM

Unable to update the hosted layer settings in the ArcGIS Enterprise portal

Last Published: September 30, 2024

Description

In some instances, when attempting to update the settings of a hosted layer, the process fails and returns the following error message:

Error:
Save wasn't successful. Try again later.
The Save wasn't successful error message

Additionally, more information can be viewed in the browser developer tools and network tab.

Cause

  • The portal's allowedProxyHosts property does not include the ArcGIS server domain URL.
  • The certificate authority (CA)-signed certificate is invalid or expired.

Solution or Workaround

Depending on the cause, refer to one of the following solutions:

Add the ArcGIS Server domain URL into the ArcGIS Portal Administrator Directory

Add the ArcGIS Server domain URL in the Configuration field in the ArcGIS Portal Administrator Directory. Refer to Portal for ArcGIS: Restrict the portal's proxy capability for instructions.

Import a CA-signed certificate into Portal for ArcGIS and ArcGIS Server

  1. Obtain a CA-signed certificate. Refer to Portal for ArcGIS: Generate a new CA-signed certificate for instructions.
  2. Import an existing CA-signed certificate into the Portal for ArcGIS. Refer to Portal for ArcGIS: Use an existing CA-signed certificate for instructions.
  3. Import an existing CA-signed certificate into ArcGIS Server. Refer to ArcGIS Server: Configure ArcGIS Server with an existing CA-signed certificate for instructions.

Article ID: 000033076

Software:
  • Portal for ArcGIS
  • ArcGIS Server
  • ArcGIS Enterprise 11 1
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2

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