PROBLEM

Unable to run the portal health check after upgrading to Portal for ArcGIS 10.8.1

Last Published: August 12, 2021

Description

The Portal for ArcGIS health check is used to determine if all the available portal machines are able to receive and process requests. The portal health check can be accessed using the following URLs:

  • localhost:
https://Portalmachine.com:7443/arcgis/portaladmin/healthCheck
  • Web Adaptor
https://WebAdaptorMachine.com/webadaptor/portaladmin/healthCheck
Note:
The URL is case-sensitive. Ensure 'healthCheck' is correctly appended to the Enterprise URLs to avoid receiving Error 404 messages.

In some instances, running the health check via ArcGIS Web Adaptor after upgrading to Portal for ArcGIS 10.8.1 returns the following error message:

Error:
Could not access any Portal machines. Please contact your system administrator.
The error message returned when performing a Portal for ArcGIS health check

Cause

This is a known issue related to BUG-000136092 in ArcGIS Web Adaptor (IIS) 10.8.1 where network requests fail, and ArcGIS Enterprise becomes unresponsive.

Solution or Workaround

Download and install the ArcGIS Web Adaptor (IIS) 10.8.1 Stability Patch to resolve the issue. After installing the patch, unregister and reconfigure ArcGIS Web Adaptor with Portal for ArcGIS. Refer to ArcGIS Enterprise: Unregistering ArcGIS Web Adaptor with Portal for ArcGIS for steps to do this.

Article ID:000026032

Software:
  • Portal for ArcGIS
  • ArcGIS Web Adaptor

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