PROBLEM

Unable to run the backupdatastore or updatelicense command utility in ArcGIS Enterprise

Last Published: April 11, 2023

Description

In an ArcGIS Enterprise deployment, attempts to run the backupdatastore or updatelicense utility in the Command Prompt window fail, and return the following error message:

Error:   
Error encountered: Failed to generate a token for a user. Incorrect credentials provided.
The error message as it appears in the Command Prompt window.

When the describedatastore utility is run on the machine, either ‘Owning system URL’, ‘Portal for ArcGIS URL’, or both are missing a URL.

Cause

  • The port used by ArcGIS Data Store is not open.
  • The relational data store is corrupted.

Solution or Workaround

Note:
The solutions below do not apply for the updatelicense utility issue in ArcGIS Data Store 11.0 and later as the updatelicense command utility is no longer used. The ArcGIS Data Store configuration updates the renewed license. Refer to Portal for ArcGIS: updatelicense for more information.

Depending on the cause, use one of the solutions below to resolve the issue.

Open the required port for ArcGIS Data Store

Contact the organization's IT Department to open the required port for ArcGIS Data Store. Refer to ArcGIS Enterprise: Ports used by ArcGIS Data Store for more information.

Reinstall and revert ArcGIS Data Store to the previous backup

Warning: 
Esri recommends creating a machine snapshot before proceeding with the following workflow. Contact the organization's IT Department for further assistance.
  1. On the primary data store machine, run the listbackups utility in the Command Prompt window to verify any previous backups.
  2. Unregister the relational data store from the ArcGIS Enterprise deployment.
    1. In ArcGIS Server Manager, navigate to Site > Data Stores.
    2. Click the Unregister The Unregister icon button to unregister the relational data store.
    3. In the ArcGIS Server Administrator Directory, navigate to data > items > enterpriseDatabase.
    4. Click the data store ID under Child Items and click Machines to ensure the data store machine is removed.
Note:
If the data store machine is still registered, click the machine’s fully qualified domain name (FQDN) and select remove.
  1. Uninstall ArcGIS Data Store and delete any remaining folder in:
<InstallationDirectory>\ArcGIS\DataStore
<InstallationDirectory>\arcgisdatastore
  1. Reinstall ArcGIS Data Store. Once the installation is completed, do not proceed with the configuration wizard.
  2. In the Command Prompt window, run the restoredatastore utility if there are any previously listed data store backups.
  3. Run the describedatastore utility and search for ‘Owning system URL’ and ‘Portal ArcGIS URL’ to ensure the URLs are available.

Article ID: 000027286

Software:
  • ArcGIS Data Store

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