PROBLEM

Unable to publish data from ArcGIS Pro to ArcGIS Online

Last Published: November 5, 2020

Description

In some instances, attempts to publish data from ArcGIS Pro to ArcGIS Online fail and return the following error messages:

Error:
External component has thrown an exception.
Error:
Failed to get the user connection.
Image showing the error message: External component has thrown an exception.
Image showing the error message: Failed to get the user connection.

Cause

This issue can occur due to a network disruption wherein a connection is not established between ArcGIS Pro and ArcGIS Online.

Solution or Workaround

Choose either one of the methods provided to resolve the problem.

Add data directly in ArcGIS Online

Log in to ArcGIS Online with the same credentials used for ArcGIS Pro, and add data to the ArcGIS Online Content page.

Note:
Ensure the ArcGIS Online account is active with privileges to create content.

Publish the data from a different location

In ArcGIS Pro, copy the data layer to a different dataset in a local drive on the machine or another network location, and publish the copied data. Refer to ArcGIS Online: Publish from ArcGIS Pro or ArcMap for more information.

Restart ArcGIS Pro

Close the current session of ArcGIS Pro, and restart the local machine. Start ArcGIS Pro, create a new project, and publish the data.

Reinstall ArcGIS Pro

Refer to ArcGIS Pro: Uninstall ArcGIS Pro for steps to perform a clean uninstall of ArcGIS Pro. Reinstall the latest version of ArcGIS Pro, and publish the data to ArcGIS Online. Refer to ArcGIS Pro: Download, install, and authorize for more information.

Article ID: 000023952

Software:
  • ArcGIS Online
  • ArcGIS Pro 2 x

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