PROBLEM

Unable to open Portal for ArcGIS home page via port 7443

Last Published: April 25, 2020

Description

Attempting to access the Portal for ArcGIS home page via localhost or via the Fully Qualified Domain Name (FQDN) with port 7443 fails. Portal logs show an issue with the certificate.

Image of the Portal for ArcGIS log message

In a federated environment, accessing ArcGIS Server Manager also fails.

Cause

This issue is caused by an expired CA/Domain certificate on the Portal for ArcGIS web server.

Solution or Workaround

To resolve the issue, follow the steps below:

  1. Run services.msc, and stop the Portal for ArcGIS service.
  2. Use Notepad to open the server.xml file in the following directory:
C:\Program Files\ArcGIS\Portal\framework\runtime\tomcat\conf
  1. Find the keyAlias parameter, and replace the existing certificate name with portal.
  2. Restart the Portal for ArcGIS service.

The Portal for ArcGIS home page can now be accessed. Replace the portal self-signed certificate with a renewed CA/Domain certificate when it becomes available.

Article ID: 000021689

Software:
  • Portal for ArcGIS

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