PROBLEM

Unable to log in to ArcGIS Pro on a machine despite using valid organization credentials

Last Published: December 28, 2020

Description

In some instances, when attempting to log in to ArcGIS Pro on a machine using valid credentials and ArcGIS Pro license, the following error messages are returned:

Error:
The username you entered is not a member of this organization.
Error:
The number of licenses assigned to users exceeds the number of licenses available in your organization. Please contact your administrator to reconfigure your organization's licenses.

Attempting to troubleshoot the issue by setting the ArcGIS Online website as a trusted site on the internet browser return ‘View Certificate’ warnings.

However, logging in to ArcGIS Pro on another machine using the same credentials is successful.

Cause

The ArcGIS Pro profile on the machine is corrupted.

Solution or Workaround

To resolve this issue, complete the steps below. Perform a soft reset by renaming the roaming and local profiles, and editing the Windows registry for ArcGIS Online For Pro.

Rename the roaming and local profiles

  1. Close all ArcGIS applications on the machine.
  2. Open File Explorer, and navigate to the AppData folder.
C:\Users\YourUsername\AppData
Note:
The AppData folder is hidden. To display hidden folders, refer to Microsoft Windows support: Show hidden files.
  1. In the AppData folder, navigate to the Roaming and Local folders, and rename ArcGISPro to ArcGISPro_old.
    1. Rename the ArcGISPro folder in the roaming profile.
C:\Users\YourUsername\AppData\Roaming\Esri\ArcGISPro
Image showing the ArcGISPro folder under the AppData Roaming profile
  1. Rename the ArcGISPro folder in the local profile.
C:\Users\YourUsername\AppData\Local\ESRI\ArcGISPro
Image showing the ArcGISPro folder under the AppData Local profile
  1. Close the File Explorer window.

Make edits in the Registry Editor

Warning:
The instructions below include making changes to essential parts of the operating system. Esri recommends performing a backup of the operating system and files, including the registry, before proceeding.
Esri cannot guarantee results from incorrect modifications while following these instructions. Exercise caution. Consult a qualified computer systems professional if necessary.
  1. Open Windows Start Menu.
  2. In the search bar, type regedit, and press Enter. If prompted, click Yes in the User Account Control window.
Image showing regedit in the Windows Start Menu
  1. In the Registry Editor window, expand the HKEY_CURRENT_USER folder.
  2. Expand the SOFTWARE folder.
  3. Expand the ESRI folder.
  4. Right-click the ArcGIS Online For Pro folder, and rename the folder to ArcGIS Online For Pro_old.
Image showing the ArcGIS Online for Pro folder in the Registry Editor
  1. Close the Registry Editor window.
  2. Restart the machine.
Note:
Alternatively, if a soft reset does not resolve the issue, refer to Esri Belux: Clean uninstall of ArcGIS Pro for instructions to perform a clean uninstall of ArcGIS Pro.

Article ID: 000024480

Software:
  • ArcGIS Pro 2 7 x
  • ArcGIS Pro 2 x

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