PROBLEM

Unable to launch ModelBuilder after an ArcGIS Desktop upgrade

Last Published: October 6, 2021

Description

In some instances, after an ArcGIS Desktop upgrade, ModelBuilder fails to launch in ArcMap.

Cause

This issue occurs when ArcGIS Desktop modules are corrupted during the upgrade process, causing the application to crash.

Solution or Workaround

To resolve the issue, run the ArcGIS Desktop repair wizard to repair the software.

  1. On the machine, navigate to Control Panel.
  2. Navigate to Programs and click Uninstall a program.
  3. Select ArcGIS Desktop <version number> and click Uninstall/Change to open the software's setup window. If prompted, click Yes.
  4. Select Repair and click Next.
The ArcGIS Desktop setup page showing the repair option
  1. Click Finish.
  2. Open ArcMap and launch ModelBuilder.

Article ID: 000025539

Software:
  • ArcMap 10 6
  • ArcMap 10 7
  • ArcMap 10 8

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