PROBLEM

Unable to install or update ArcGIS Pro 3.5 and later

First Published: September 29, 2025
Last Published: May 19, 2026

Description

Attempts to install, update, or apply a patch to ArcGIS Pro 3.5 or later fails, and the Windows Installer returns the following error message:

Error: 
The feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternate path to a folder containing the installation package 'ArcGISPro.msi' in the box below

Cause

  • Windows Installer does not work as intended or the product registry subkey is corrupted.
  • Windows Installer cannot locate the original ArcGISPro.msi file required for installation, updates, or patching.

Solution or Workaround

Delete the corrupted subkey folder using Registry Editor

Warning:
The instructions below include making changes to essential parts of the operating system. Esri recommends performing a backup of the operating system and files, including the registry, before proceeding.

Esri cannot guarantee results from incorrect modifications while following these instructions. Exercise caution. Consult a qualified computer systems professional if necessary.
  1. Type regedit into the Windows search bar and click Registry Editor.
Note:
If prompted, click Yes in the User Account Control window to allow the app to make changes to the device.
  1. In the Registry Editor left pane, click the drop-down arrows Drop-down arrow in Registry Editor to expand the registry key folders in the folder tree.
  2. Scroll down and navigate to the following location:
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products
  1. Click every registry subkey folder under Products to locate the corrupted program.
Note:
To identify the corrupted program, click each subkey folder, then double-click ProductName on the right. Check the Value Data in the Edit String panel. Signs of a corrupted program include the Value Data box being empty, missing data, or containing garbled and unreadable characters. Delete the subkey folder if the ProductName matches the product being installed (ArcGIS Pro).
The identified corrupted program in the Registry Editor
  1. Right-click the corrupted subkey folders and click Delete.
  2. Close Registry Editor.
  3. Restart the machine.
  4. Reattempt the installation.

Perform a clean uninstall and reinstall of ArcGIS Pro

Perform a clean uninstall of ArcGIS Pro to remove corrupted installation or registry entries, then reinstall using new installation files. Refer to How To: Perform a clean uninstall and reinstall of ArcGIS Pro for instructions.

Article ID: 000038294

Software:
  • ArcGIS Pro

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