Description
Attempting to install ArcGIS Pro through Windows Command Prompt fails and returns the following error message:
Error:
1311: Source file not found.
Cause
This error occurs due to existing restrictions on the folders. The Windows Command Prompt identifies the installer file as non-existent due to the restrictions set. For example, when the file is in a cloud storage folder, the Command Prompt fails to identify the installer file because the cloud folder is not directly linked to the machine’s folder connection. The following are folders that may cause this issue:
- Cloud storage folder.
- Shared network folder. Shared network folders may contain restrictions set by the owner of the folder. Hence, the limited capabilities, such as read and write access may cause the issue.
- Restricted folder. Potentially by organizations to limit item sharing.
Solution or Workaround
Move the ArcGIS Pro installer to a local file on the machine
- Access the cloud or shared network drive folder.
- Navigate to the folder with the ArcGIS Pro installer, right-click the ArcGIS Pro installer and select Copy.
- Open a new folder on the Local Drive.
- Paste the installer in the new folder and run the installer.
Check the permission of the folder containing the installer
- Right-click the folder containing the ArcGIS Pro installer and select Properties. In this example, the folder name 'ArcGISPro' is used.
- In the <folder_name> Properties dialog box, select the Security tab.
- Under Group or user names, click Edit.
- In the Permission for <folder_name> dialog box, select the username or group for ArcGIS Pro installation.
- Under Permissions for <user_name>, uncheck all the Deny check boxes.
- Click Apply.
- Click OK in the Permissions for <folder name> dialog boxes.
- Run the installer.