PROBLEM

Unable to edit Microsoft Excel or CSV tables in ArcGIS Pro

Last Published: August 19, 2024

Description

In ArcGIS Pro, performing editing operations such as adding fields, calculating values, or editing values in cells is not available for external tables, such as Microsoft Excel and CSV tables.

Cause

The necessary drivers are not downloaded and installed correctly on the computer. In ArcGIS Pro, some tables are not editable, such as text files (.xls, .xlsx, .txt, and .csv), as these tables are read-only. While data can be viewed and analyzed from these external tables, direct editing operations such as adding fields, calculating values, or editing cell values within ArcGIS Pro cannot be performed. For more information, refer to ArcGIS Pro: Edit a value in a table cell.

Solution or Workaround

Download and install the appropriate drivers based on the ArcGIS Pro version

To determine and install the appropriate drivers, refer to ArcGIS Pro: Install the drivers to work with Microsoft Excel files for more information.

Convert the external tables to geodatabase tables

If the drivers cannot be installed due to corrupted system files, limited disk space, or other issues, convert the Excel or CSV tables to geodatabase tables to enable editing. Use one of these tools to do so:

Edit the tables externally and re-add the tables

Edit the tables externally using Microsoft Excel and re-add the updated tables to ArcGIS Pro. This method allows the necessary modifications to be made before importing the data back into ArcGIS Pro for further analysis and mapping.

Article ID: 000033224

Software:
  • ArcGIS Pro 3 1
  • ArcGIS Pro 3 3
  • ArcGIS Pro 3 2

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