PROBLEM

Unable to add layers from ArcGIS Online using an Enterprise account in ArcGIS for Excel

Last Published: January 28, 2025

Description

When using an ArcGIS Enterprise account in ArcGIS for Excel, attempting to add layers from ArcGIS Online fails and returns the following error message:

Error:
Failed to fetch
The error message

Cause

When cross-domain origin requests are configured in the ArcGIS Enterprise portal, requests from a different domain are blocked. If the ArcGIS Online domain is not included in the Allow Origins list, the system rejects the request or requires additional authentication, causing a token-required error manifesting as the "Failed to fetch" error in ArcGIS for Excel.

Solution or Workaround

Add the ArcGIS Online domain to the Allow Origins list in the security settings of the ArcGIS Enterprise portal:

https://la.arcgis.com/

Refer to Portal for ArcGIS: Restrict cross-domain requests to your portal for instructions. This action enables cross-domain communication and prevents token authentication issues by allowing trusted requests from the domain.

Article ID: 000034156

Software:
  • ArcGIS Online
  • Portal for ArcGIS
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2
  • ArcGIS for Excel
  • ArcGIS Enterprise 11 4

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