Description
Attempting to add a new portal connection to ArcGIS Survey123 Connect returns the following error message:
Error:
"ERR_NAME_NOT_RESOLVED"
Cause
Possible causes for the error include:
- The data store is in READONLY mode, so the data store cannot be validated as no data can be sent in this mode. The error may occur if the available disk space for the data store on the machine is less than 1024 MB.
- The JSON file associated to the ArcGIS Survey123 Connect to Portal for ArcGIS connection is corrupt.
Solution or Workaround
Complete the steps below to resolve the problem.
- Increase the disk space allocated to the data store, and change the data store to READWRITE mode if necessary. Refer to Portal for ArcGIS: changedatastoremode for steps to do this.
- Validate the data store. Refer to Portal for ArcGIS: Validate the data store for the steps on how to do this.
- Navigate to the following directory:
C:\Users\<username>\ArcGIS\AppStudio\Settings
- Open the most recent JSON file in a text editor, and locate the portal URL in the portal/url field.
- Set the portal/url field to an empty string in the JSON file, to allow the new portal URL to populate the field.
- Reconnect ArcGIS Survey123 Connect to the new portal. Refer to ArcGIS Survey123: Use Survey123 with ArcGIS Enterprise for steps to do this.