PROBLEM

Unable to access the Settings tab in the ArcGIS Enterprise portal

Last Published: September 5, 2024

Description

When attempting to access the Settings tab in the ArcGIS Enterprise portal, a login window unexpectedly pops up, causing an endless loop of login attempts. Additionally, this issue is specific to the Domain Name System (DNS) URL and does not occur with the internal administrator URL, as it is not observed in the HTTPS port 7443.

Cause

The privatePortalURL property is not configured in the Portal Administrator Directory.

Solution or Workaround

  1. In the Portal Administrator Directory, set the privatePortalURL property. Refer to Step 5 in Portal for ArcGIS: Configure load balancers for further instructions.
  2. Ensure the privatePortalURL property is reflected in the ArcGIS Server security file on the machine.
    1. Launch File Explorer.
    2. Navigate to the following folder directory, which by default, is:
    C:\arcgisserver\config-store\security
    
    1. Open security-config.json.
    2. Search for the privatePortalURL property. If the property is displayed, then the Settings tab in the ArcGIS Enterprise portal is now accessible without the login prompt.

The image below shows the privatePortalURL property reflected on the machine.

The privatePortalURL property is displayed.

Article ID: 000033310

Software:
  • Portal for ArcGIS

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