Description
The ArcGIS Monitor site is inaccessible when attempting to access it. A variation of the "Unable to connect" message returns depending on the web browser used to access the ArcGIS Monitor site.
Cause
- The ArcGIS Monitor Server service is stopped.
- One or more of the ArcGIS Monitor Server processes are not running.
- The ArcGIS Monitor service account does not have permissions in the following directories:
C:\Program Files\ArcGIS\MonitorC:\Users\AppData\Local\ESRI\ArcGISMonitor
C:\Program Files\ArcGIS\Monitor
- The .env file within the configuration store folder is corrupted.
- The required port is closed.
Solution or Workaround
Depending on the cause, use one of the following workflows:
Start the ArcGIS Monitor Server service
- In the Windows search bar, type services and click the Services icon.
- In the Services window, navigate to the ArcGIS Monitor Server service and click Start.
Start the ArcGIS Monitor Server processes
- In the Windows search bar, type task manager and click the Task Manager icon.
Note:
In the Processes tab of Task Manager, ArcGIS Monitor 2024.x has five instances of ArcGIS Monitor Server and one instance of ArcGIS Monitor Agent.
- In Task Manager, click the Services tab.
- Navigate to and right-click the arcgismonitorserver service.
- Click Restart.
Grant the ArcGIS Server service account the necessary permission
Note:
The AppData folder is hidden by default. Refer to the Show hidden files drop-down in Microsoft Support: Common File Explorer options for instructions to display hidden folders.
- On the ArcGIS Monitor Server machine, in File Explorer, navigate to the ArcGISMonitor folder, which by default is located in:
C:\Users\<ArcGIS Monitor Service Account>\AppData\Local\ESRI
- Right-click the ArcGISMonitor folder and click Properties.
- Click the Security tab and click Edit… to add the ArcGIS Monitor service account to the Group or user names: section.
Note:
If the ArcGIS Monitor account is listed in the Group or user names: section, proceed to Step 8.
- In the Permissions for <folder_name> window, click Add… to display the Select Users, Computers, Service Accounts, or Groups window.
- Click Locations… and select the machine name from the list. Click OK.
- Type the relevant account name in the Enter the object names to select text box and click Check Names.
Note:
If the Multiple Names Found window is displayed, select the account name from the list, and click OK.
- Click OK.
- In the Permissions for <folder_name> window, select the account name from the Group or user names: section.
- Under the Permissions for <account_name> section, check the Allow check box for the Full Control option.
- Click Apply > OK.
- Repeat Steps 1 through 10 on the Monitor folder, which by default is located in:
C:\Program Files\ArcGIS
Generate a new configuration store folder
- In the Windows search bar, type services and click the Services icon.
- In the Services window, navigate to the ArcGIS Monitor Server service and click Stop.
Note:
The AppData folder is hidden by default. Refer to the Show hidden files drop-down in Microsoft Support: Common File Explorer options for instructions to display hidden folders.
- In File Explorer, navigate to the config-store-server folder, which by default is located in:
C:\Users\<ArcGIS Monitor Service Account>\AppData\Local\ESRI\ArcGISMonitor
- Rename the config-store-server folder to config-store-server_OLD.
- In the Windows search bar, type services and click the Services icon.
- In the Services window, navigate to the ArcGIS Monitor Server service and click Start.
Enable the ports
Enable port 30443 (HTTPS) or 30080 (HTTP). Refer to ArcGIS Monitor: Ports used by ArcGIS Monitor for more information.
Note:
Contact the organization's IT personnel to enable port 30443 (HTTPS) or 30080 (HTTP).