PROBLEM

The Validation and Repair tool stops responding or crashes during Portal for ArcGIS patch uninstallation

Last Published: July 29, 2024

Description

When running the Portal for ArcGIS Validation and Repair tool, the tool window stops responding or crashes while uninstalling patches. Checking the operation system (OS) activity does not reveal any ongoing background processes.

The following logs are returned in the Windows Event Viewer logs corresponding to each crash:

The Windows Event Viewer logs corresponding to each crash

In certain cases, the following error message is returned in the Portal for ArcGIS 10.8.1 Validation and Repair window:

Error:
There were issues uninstalling patches from your portal machine.
The error message in the Portal for ArcGIS 10.8.1 Validation and Repair tool window

When attempting to uninstall the patches from the Microsoft Windows Control Panel, the following error message is returned:

Error: 
The feature you are trying to use is on a network resource that is unavailable.
Note: 
The patches uninstallation process for Portal for ArcGIS 10.8.1 or 10.9.1 taking a longer time is anticipated. Refer to Patches and Updates: Portal for ArcGIS Validation and Repair for more information.

Cause

  • The antivirus software installed on the machine blocks or limits access to one or more patch files. The connection to the patch files may be blocked by predetermined security rules set by the organization.
  • The Validation and Repair tool is unable to search for the original Portal for ArcGIS setup file.

Solution or Workaround

Depending on the circumstance, the workarounds described below are applicable.

Disable the antivirus software and stop the remaining tasks

Contact the IT department to disable the antivirus software and rerun the Validation and Repair tool. If this does not solve the issue, apply the following steps to stop tasks from the Task Manager window and rerun the Validation and Repair tool.

  1. Press the Windows + X keys and select Task Manager from the menu. The Task Manager window opens.
  2. On the Processes tab, select Validation and Repair tool and click End task.
  3. Select 7za.exe and click End task.
  4. Close the Task Manager window.
  5. Run the Validation and Repair tool.

Run the Validation and Repair tool from the command prompt

Apply the following steps if disabling the antivirus software is not a viable option.

  1. In the Windows search box on the taskbar, search for and right-click Windows Command Prompt, then select Run as administrator.
  2. In the Administrator: Command Prompt window, run the following command to change the directory in Command Prompt to the directory containing the Validation and Repair tool.
C:/<ArcGIS Server installation directory>\<download folder>
  1. Run the Validation and Repair tool by entering the name of the tool in the command line.
ArcGIS-PFA-1081-ValidationRepair.exe
The command in the Windows Administrator: Command Prompt window

Extract the portal setup file to the correct file location

To resolve the error message, extract or download the portal setup file to the path defined in the SourceDir property in the Windows Registry. The default path for the extracted installer file is:

C:\Users\<user profile ID>\Documents\ArcGIS 10.8.1\PortalForArcGIS\SetupFiles
  1. Locate the Portal for ArcGIS setup file location:
    1. In the Windows search box on the taskbar, search for and click Registry Editor.
    2. In the Registry Editor window, copy the following file path into the Find box.
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\Portal for ArcGIS
The Find box in the Registry Editor window
  1. Identify the file path recorded in the Data column of the SourceDir property.
The Portal for ArcGIS file path in the Data column of the SourceDir property
  1. Download the Portal for ArcGIS setup file, and run the file to extract it to the SourceDir folder. Refer to How To: Download and install software from My Esri for instructions.
Warning:
Do not run the setup file after the extraction is completed. Doing so may result in overwriting the existing deployment.
  1. Run the Validation and Repair tool.

Article ID: 000032123

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise 11 1
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2

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