PROBLEM

The TrueType font symbol does not display correctly on ArcIMS map

Last Published: April 25, 2020

Description

The TrueType font symbol does not display correctly on an ArcIMS map.

Cause

The font may not be installed properly, or the font may have been created in a way that is not compatible with ArcIMS.

Solution or Workaround



  1. Determine which machine will check for fonts. This depends on the type of virtual server:

    FEATURESERVER - check on the client machine.

    IMAGESERVER - check on the spatial server machine.

    ARCMAP SERVER - check on the spatial server machine.
  2. If the machine that requires the font has a UNIX or Linux operating system, refer to the knowledge base article entitled "How can custom TrueType fonts be used in ArcIMS on Linux or UNIX?" in the Related Information section below.
  3. If the machine that has the font is using a Windows operating system, check to see if the font is available from any other programs. If the font is not available in other programs, the font most likely needs to be installed. Refer to the knowledge base article entitled "How to install or remove a font in Windows" in the Related Information section below.
  4. Verify that the correct character is being used.
  5. If the font is installed correctly and the correct character is used but the font is not working with ArcIMS, there may be a compatibility issue between ArcIMS and the way the font was created. For issues with custom fonts, refer to the knowledge base article entitled "ArcIMS - ArcMap Server does not correctly display custom fonts" in the Related Information section below.

Article ID:000003036

Software:
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic