PROBLEM

The tools of the ArcGIS for Excel add-in ribbon are unavailable in Microsoft Excel

Last Published: October 19, 2023

Description

In Microsoft Excel, when attempting to use the tools of the ArcGIS for Excel add-in, the tools on the ribbon are unavailable as shown in the image below.

The ArcGIS for Excel ribbon is unavailable

Cause

The workbook may be opened in Compatibility Mode. Compatibility Mode ensures no updated or new tools of Microsoft Office are available when working with a document in order to preserve the full editing capabilities of its earlier versions.

Solution or Workaround

Convert the workbook to a new XLSX file.

  1. In Microsoft Excel, click File > Info.
  2. Under Compatability Mode, click the Convert button.
  3. Rename the workbook using the (.xlsx) format.
  4. Click Save.
CompatibilityModeSetting.png
Note: 
Alternatively, save the workbook to a newer version. For example, as opposed to an XLS file, save the workbook as a XLSX file. Refer to Microsoft Excel: Save your workbook for instructions. Then close and reopen the new file.
Note: 
To disable Compatibility Mode, right-click the Excel program and click Properties. Click the Compatibility tab and uncheck the Run this program in compatibility mode for: check box under Compatibility mode. Click Apply > OK.

The tools of the ArcGIS for Excel add-in are available as shown in the image below.

The features of the ArcGIS for Excel add-in are available

Article ID: 000031159

Software:
  • ArcGIS for Office 5 0

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options