Description
The Hub site is not displayed on the Overview tab in ArcGIS Hub even though the site is listed in ArcGIS Online, as shown below.
Cause
In the JSON script of the Hub site, under the typeKeyword section, the Hub site is listed as 'hubPage' instead of 'hubSite'.
Solution or Workaround
Identify whether 'hubPage' is listed in the JSON script of the Hub site.
- Log in to ArcGIS Online and click Content > My Groups.
- Search for and click the Hub site application.
- On the item details page, right-click the page and select Inspect from the drop-down menu.
- Click the Network tab.
- Refresh the Hub site's item details page.
- Find the item ID of the Hub site in the Name column by referring to the URL at the top of the window. Click the item ID.
- Click the Response tab.
- Search for hubPage in the JSON script.
If the Hub site is listed as 'hubPage' instead of 'hubSite', use either one of the workarounds provided below.
- Recreate the Hub site in ArcGIS Hub. Clone the Hub site in ArcGIS Hub to create a new version of the site and the items displayed on the layout. Refer to ArcGIS Hub: Clone a site for further instructions.
- Edit the Hub site's JSON file in ArcGIS Online Assistant. This workaround is performed in ArcGIS Online Assistant as the JSON script cannot be edited in ArcGIS Online.
Warning:
ArcGIS Online Assistant is not supported by Esri Support Services.
Warning:
Esri does not recommend modifying the JSON script of the item as it may corrupt or break the item.
- Open and log in to ArcGIS Online Assistant.
- Click the I want to... drop-down menu and select View an Item's JSON.
- In the item's list pane to the left of the page, search for and expand the Hub site.
- Click the Hub site with Hub Site Application.
- Click Edit JSON.
- Search for and replace hubPage with hubSite.
- Click JSON is valid. Click to save.
The image below shows the Hub site, Hub Test, now displayed on the Overview tab in ArcGIS Hub.