PROBLEM

The Editor widget is empty in ArcGIS Experience Builder

Last Published: January 22, 2024

Description

When launching a web experience from ArcGIS Online, the Editor widget does not show any editable layers and returns the following error:

Error: 
No editable layers found.
The Editor widget appears empty in ArcGIS Online

When launching the web experience in Portal for ArcGIS, the widget is completely empty, as shown in the following image.

The Editor widget appears empty in Portal for ArcGIS

Cause

  • All layers specified in the widget are not editable. The Editor widget uses layers from a web map referenced in the Map widget inserted into the web experience. Even if the web map is shared publicly, the layer it references must be editable for use.
  • The user viewing the web experience has a Viewer role. The layer is non-editable to users with a Viewer role even if editing is enabled on the layer.

Solution or Workaround

Note:
The user interface for the workflows are similar in Portal for ArcGIS and ArcGIS Online.

The following image demonstrates the Editor widget working as expected.

The Editor widget working as expected

Article ID: 000031809

Software:
  • ArcGIS Online
  • Portal for ArcGIS
  • ArcGIS Enterprise 11 0
  • ArcGIS Enterprise 11 1
  • ArcGIS Experience Builder
  • ArcGIS Enterprise 11 2

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options