PROBLEM

The Draw widget symbology does not display in ArcGIS Experience Builder

Last Published: May 20, 2024

Description

In ArcGIS Enterprise’s Experience Builder, selecting a tool from the ‘Select draw mode’ option in the Draw widget results does not display the symbology in the Preview section. Instead, a loading process continues indefinitely, as shown in the image below.

The symbology not displayed in the Draw widget in ArcGIS Experience Builder.

Cause

The Can Search Public? parameter is set to False in the ArcGIS Portal Directory. Setting it to False causes empty results in ArcGIS Experience Builder as the search query is unable to retrieve the ID of the Esri symbols.

Solution or Workaround

  1. Log in to the ArcGIS Portal Directory.
  2. On the User (siteadmin) page, for Org ID:, click the organization ID.
  3. Scroll to the bottom of the page, for Supported Operations:, click Update.
  4. On the Update Account page, for Can Search Public? select True.
The Update Account page with the Can Search Public set to True.
  1. Click Update Organization.

The image below shows the symbology displayed in the Draw widget in ArcGIS Experience Builder.

The symbology displayed in the Draw widget.

Article ID: 000032505

Software:
  • ArcGIS Experience Builder

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