PROBLEM

The Copy Raster tool fails with ERROR 999999 in ArcGIS Pro

Last Published: June 15, 2021

Description

In ArcGIS Pro, when attempting to run the Copy Raster tool, it fails and returns the ERROR 999999 message.

Error:   
ERROR 999999: Something unexpected caused the tool to fail. Contact Esri Technical Support (http://esriurl.com/support) to Report a Bug, and refer to the error help for potential solutions or workarounds.
The screeenshot image shows the ERROR 999999 message returned when running the Copy Raster tool.

Cause

This issue occurs when more than one processor is specified in the Parallel Processing Factor field in the geoprocessing environment setting. This is a known limitation. Refer to BUG-000129060 for more information.

Solution or Workaround

To resolve the issue, use only one processor when running the Copy Raster tool. Complete the steps below to do so:

  1. On the ArcGIS Pro top ribbon, click the Analysis tab > Tools.
  2. In the Geoprocessing pane, search for Copy Raster (Data Management Tools), and click it. The Copy Raster window opens.
  3. In the Copy Raster window, click Parameters and fill in all the required fields.
  4. In the Copy Raster window, click Environments. In the Parallel Processing section, delete the value in the Parallel Processing Factor field.
  5. Click Run.
The Copy Raster tool displaying the Environment setting with the Parallel Processing Factor parameter.
Note:
If using Python to run the Copy Raster tool, specify the Parallel Processing Factor component and its value as 'arcpy.env.parallelProcessingFactor = 0' in the Python script.

Article ID: 000024626

Software:
  • ArcGIS Pro 2 8 x
  • ArcGIS Pro 2 7 x
  • ArcGIS Pro 2 x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options