PROBLEM

The Change Version option is not available in ArcGIS Pro

Last Published: April 28, 2022

Description

In ArcGIS Pro, the Change Version option is not available after right-clicking the data source from the Contents pane.

The image below shows the Change Version not available in ArcGIS Pro.

The Contents pane with the Change Version not available.

Cause

  • The data source is not an enterprise geodatabase.
  • The dataset is not registered as branch versioned.

Solution or Workaround

Use one of the methods below to resolve the issue.

Connect to an enterprise geodatabase

In ArcGIS Pro, set up a connection to an enterprise geodatabase. Refer to ArcGIS Pro: Set up a database connection for instructions.

Note:
Alternatively, use the Create Enterprise Geodatabase or Enable Enterprise Geodatabase tools to create a new enterprise geodatabase.

Register the dataset as branch versioned

In ArcGIS Pro, register the dataset as branch versioned instead of traditional versioned. Refer to ArcGIS Pro: Register a dataset as branch versioned for instructions.

Use the Change Version geoprocessing tool

In ArcGIS Pro, use the Change Version geoprocessing tool instead of right-clicking the data source from the Contents pane to change the version. Refer to ArcGIS Pro: Change Version (Data Management) for instructions and information.

Article ID: 000027591

Software:
  • ArcGIS Pro 2 8 x
  • ArcGIS Pro 2 7 x
  • ArcGIS Pro 2 x

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