PROBLEM

The Attachment Viewer template in ArcGIS Instant Apps does not display all layer attachments

Last Published: October 13, 2022

Description

In ArcGIS Enterprise, ArcGIS Instant Apps is a configurable web mapping app with no coding required. When creating an app, the Attachment Viewer template from the list of default templates can be chosen to display features with attachments in a hosted feature service. In some cases, not all the attachments are displayed when cycling through the features in the Attachment Viewer app even though the attachments can be viewed in Map Viewer and the attribute table.

Cause

The number of items with attachments is higher than the default maxRecordCount value set in the ArcGIS Server Administrator Directory.

Solution or Workaround

Increase the maxRecordCount for the hosted service in the ArcGIS Server Administrator Directory.

  1. Log in to the ArcGIS Server Administrator Directory as an administrator.
  2. Navigate to Services > Hosted.
  3. Select the feature service under Services.
  4. At the bottom of the page, click edit under Supported Operations.
The edit botton under Supported Operations
  1. Search for the maxRecordCount parameter under Service Properties.
  2. Increase the default maxRecordCount value.
  3. Click Save Edits.
The maxRecordCount value to be edited and the Save Edits button

Article ID: 000027505

Software:
  • Portal for ArcGIS
  • ArcGIS Server

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options