PROBLEM

The ArcGIS Sign In window prompts multiple times in ArcGIS Pro

Last Published: April 1, 2024

Description

When opening an existing project in ArcGIS Pro, the map fails to load, and the ArcGIS Sign In window prompts multiple times;, and reappears each time it is closed.

After closing the log-in window multiple times, the map loads but the layers are not displayed, and red exclamation points appear next to each layer in the Contents pane as shown in the image below.

The layers in the Contents pane and the blank map view in ArcGIS Pro.

In some instances, the ArcGIS Sign In window prompts even though ArcGIS Pro is logged in to an ArcGIS Enterprise portal.

Cause

The existing project contains items from ArcGIS Online that are not accessible to the public, such as basemaps or feature layers.

Solution or Workaround

Identify and remove the items from the project

In ArcGIS Pro, identify the items and remove them from the project. Refer to ArcGIS Pro: Remove or delete project items for instructions. Consider the following when identifying these items in the project:

Change the sharing level of the items in ArcGIS Online

In ArcGIS Online, share the items with everyone to make them accessible to the public. Change the sharing level of the items to Everyone. Refer to ArcGIS Online: Share items with everyone for instructions and ArcGIS Online: Best practices for sharing for more information.

Article ID: 000032231

Software:
  • ArcGIS Online
  • ArcGIS Pro 3 1
  • ArcGIS Pro 3 0
  • ArcGIS Pro 3 2
  • ArcGIS Living Atlas

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