PROBLEM

The ArcGIS login window prompt disappears when logging in to the ArcGIS Hub initiative site

Last Published: April 14, 2024

Description

When attempting to log in to the ArcGIS Hub initiative site, the login window prompt displays and immediately disappears, preventing users from logging in with their ArcGIS Online credentials and accessing the ArcGIS Hub initiative site.

Cause

The custom URL for the ArcGIS Hub initiative is blocked by the organization's Cross-Origin Resource Sharing (CORS) policy.

Solution or Workaround

Add the custom URL to the ArcGIS Online Allow Origins settings

  1. Log in to ArcGIS Online.
  2. Click Organization > Settings > Security.
  3. Scroll down to Allow Origins.
  4. Enter the domain name of the site hosting the web app to access the ArcGIS Hub initiative site.
  5. Click Add domain.
  6. Click Save.

Create exceptions in the organization's Cross-Origin Resource Sharing (CORS) policy

Contact the organization's IT to create exceptions for the custom URL in the organization's CORS policy.

Article ID: 000032227

Software:
  • Other

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