PROBLEM

Survey responses are not displayed in view-only mode in ArcGIS Survey123

Last Published: April 16, 2024

Description

Web form URL parameters can be used in ArcGIS Survey123 to edit existing records and open surveys in view-only mode using the 'mode=edit' or 'mode=view' parameter. In some instances, when opening a survey response, some responses are not displayed when the survey form is opened in view-only mode while they display as usual when the survey response is opened in edit mode.

This is observed in the images below where the response to the question Age is only displayed in edit mode whereas it is not visible in view-only mode.

The survey in view-only mode.
The survey in edit mode.

Cause

When a survey is shared for viewing, the ArcGIS Survey123 web app uses a unique feature layer view so participants are unable to edit the data. This feature layer view is created only when survey results are shared for viewing. If a new field is added to the hosted feature layer of the survey, but not synced across to the view layer, some information is not updated, preventing some responses from being displayed.

Solution or Workaround

Update the hosted feature layer view and ensure all fields are selected to reflect on the survey. Refer to ArcGIS Online: Edit a hosted feature layer view definition for further instructions.

Article ID: 000032203

Software:
  • ArcGIS Online
  • ArcGIS Survey123 Website

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options