PROBLEM

Recorded fields are empty for viewing and editing in the ArcGIS Survey123 field app Inbox

Last Published: June 4, 2024

Description

In ArcGIS Survey123 Connect, when the Inbox option is enabled, the inbox in the ArcGIS Survey123 field app can be set to allow viewing and editing. However, when the 'Allow inbox surveys to be viewed' and 'Allow inbox surveys to be edited' options are toggled on, some of the previously recorded fields are not displayed for viewing and editing in the inbox. When the Edit option is selected, only new records can be added to the affected fields.

Cause

  • The 'repeat question' type is used in a survey. By design, fields with a 'repeat question' type in a survey are not editable via the field app inbox. This design causes the previously recorded fields inside a 'repeat question' to appear empty when viewing and editing.
  • The ‘relevant’ column is used in a nested repeat. The use of the ‘relevant’ column is practical for controlling the visibility of questions based on the answer to the previous field. Moreover, it automatically deletes the previous record from a hidden field (when the relevant expression evaluates to true) during editing. However, when used in a nested repeat, the ‘relevant’ field’s first recorded answer appears empty when viewing and editing via the inbox. Meanwhile, the subsequent answers in a nested repeat are displayed as expected, as demonstrated in the images below.
The first recorded answer that is displayed as empty in the inbox
The second recorded answer that is displayed as expected in the inbox
The recorded survey answers on the Data tab in the ArcGIS Survey123 website

Solution or Workaround

Select one of the options below to ensure all previously recorded fields are displayed in the ArcGIS Survey123 field app Inbox.

Specify the query in the bind::esri:parameters column for repeat questions

To change the default behavior of a repeat field, specify the expression below in the bind::esri:parameters column. Refer to ArcGIS Survey123: Repeats for more information.

query allowUpdates=True

A survey can have a repeat with multiple nested repeats; the expression must be set for all begin repeat rows, in the bind::esri:parameter column, not just for the parent repeat. Not specifying the expression for the parent repeat causes the issue to occur in all repeat questions even if the expression is already specified for the nested repeat questions.

Specify the question visibility expression in the body::esri:visible column

To display the field with a question visibility setting in the field app inbox, specify the expression below in the body::esri:visible column instead of the relevant column. In this example, selected(${environment},'indoor') is used.

selected(${},'')
The question visibility expression in the body::esri:visible column

When a recorded field is edited with this visibility setting and the edited answer does not comply with the body::esri:visible rule, the question with the previously recorded answer is hidden from the inbox view. However, the record is still retained on the Data tab of the ArcGIS Survey123 website. This could lead to incoherent records if the previously recorded data for the hidden question is no longer needed after an edit. To remove the previously recorded data when using the body::esri:visible column, manually delete the recorded answer from the question with the visibility setting in the inbox before resending the edited record.

Article ID: 000032579

Software:
  • ArcGIS Survey123 Field App iOS
  • ArcGIS Survey123 Field App Android
  • ArcGIS Survey123 Connect
  • ArcGIS Survey123 Website

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