Description
In ArcGIS Field Maps, hosted feature layers are often modified after data collection begins, for example by adding new fields to support additional attributes. However, in some instances, fields added to an existing hosted feature layer using the Data tab in ArcGIS Online are not visible in the ArcGIS Field Maps mobile app.
Cause
ArcGIS Field Maps caches a layer’s schema and configuration (fields, aliases, domains, forms, pop-ups, and offline map areas) the first time a map is opened on a device. The cache is not automatically refreshed when changes are made in ArcGIS Online.
As a result, fields added later do not appear in the mobile app if the map was previously opened and cached.
Solution or Workaround
Update the form in Map Viewer
- In ArcGIS Online, open the web map in Map Viewer.
- On the Settings (light) toolbar, click Configure editing > Forms.
- In the Form builder pane, review the Fields tab, and verify the newly added field has not been included in the form.
- Select Add all or add the fields individually, then click OK, and save the map.

- Open the Field Maps mobile application.
- Click Options > Reload Map to reload the map and ensure the updated configuration is downloaded.
- The new field is now visible and available for data collection in the form.
Update the form in Field Maps Designer
- Open the web map in Field Maps Designer.
- Click the Forms tab and select the target layer.
- In the Form builder pane, review the Fields tab and verify that the newly added field is not included in the form.
- Click Add all or add fields individually, then save the changes.
- Repeat Steps 5 through 6 from the first workaround to view the new field.