PROBLEM

Layers and labels do not display in an ArcGIS Pro project

Last Published: December 28, 2020

Description

When working on an ArcGIS Pro project, in some instances, the layers cannot be viewed in the Contents pane, or the labels are not displayed.

Cause

In ArcGIS Pro, cache is used to optimize display performance when working on a project. The accumulated cache on the project consumes the machine’s drive space, resulting in performance issues that cause the layers and labels to not display properly.

Solution or Workaround

Choose one of the workarounds below to resolve the issue.

Clear the display cache of the application

Note:
This solution closes and reopens the project when executed.
  1. In ArcGIS Pro, navigate to Project > Options.
  2. In the Options window, on the sidebar under Application, click Display.
  3. On the Set quality and performance options for drawing maps and scenes page, check the Clear cache (current cache size <value>) check box.
  4. Click OK.
Image of the Options window showing the Display options

Delete the temporary files on the machine

  1. On the machine, navigate to the following folder in File Explorer:
C:\Users\USERNAME\AppData\Local\Temp. 
Note:
The AppData folder is hidden. Refer to Microsoft Windows: Show hidden files  to display hidden folders.
  1. Delete the files in the folder.

Clear the cache or select the caching options of a specific layer

Follow this workflow to clear the cache or select a caching option of a specific layer to improve performance when working on an ArcGIS Pro project. Refer to ArcGIS Pro: Cache with feature layers for more information.

To apply the same caching options to multiple layers in the same project, on the Contents pane, press and hold the Ctrl button on the keyboard, and click to select the layers.

Image showing the Layer Properties window displaying the Cache options

Article ID:000024643

Software:
  • ArcGIS Pro 2 x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options